8.1. Main Window

Table of Contents

8.1.1. Main Window Actions
8.1.2. Perspectives
8.1.3. Control Bar Window

8.1.1. Main Window Actions

Table of Contents

8.1.1.1. Add Symbolic Name action
8.1.1.2. Activate Editor action
8.1.1.3. Check Object Existence action
8.1.1.4. Close action
8.1.1.5. Close All action
8.1.1.6. Close Perspective action
8.1.1.7. Close All Perspectives action
8.1.1.8. Content Assist action
8.1.1.9. Convert Line Delimiters To action
8.1.1.10. Copy action
8.1.1.11. Customize Perspective action
8.1.1.12. Cut action
8.1.1.13. Delete action
8.1.1.14. Delete Test Suite action
8.1.1.15. File action
8.1.1.16. Find and Replace action
8.1.1.17. Find Next action
8.1.1.18. Find Previous action
8.1.1.19. Import Test Resource action
8.1.1.20. Key Assist action
8.1.1.21. Last Edit Location action
8.1.1.22. Launch AUT action
8.1.1.23. Manage AUTs action
8.1.1.24. Maximize Active View or Editor action
8.1.1.25. Minimize Active View or Editor action
8.1.1.26. Move action
8.1.1.27. New action
8.1.1.28. New Test Case action
8.1.1.29. New Test Suite action
8.1.1.30. Next Annotation action
8.1.1.31. Next Editor action
8.1.1.32. Next Perspective action
8.1.1.33. Next View action
8.1.1.34. Open File action
8.1.1.35. Open Test Suite action
8.1.1.36. Open Perspective action
8.1.1.37. Paste action
8.1.1.38. Preferences action
8.1.1.39. Prev­ious An­no­ta­tion action
8.1.1.40. Previous Editor action
8.1.1.41. Previous Perspective action
8.1.1.42. Previous View action
8.1.1.43. Project action
8.1.1.44. Properties action
8.1.1.45. Quick Access action
8.1.1.46. Quit AUT action
8.1.1.47. Re­cord Snip­pet action
8.1.1.48. Record Test Case action
8.1.1.49. Redo action
8.1.1.50. Refresh action
8.1.1.51. Remove All Breakpoints action
8.1.1.52. Rename action
8.1.1.53. Reset Perspective action
8.1.1.54. Resume action
8.1.1.55. Run Test Case action
8.1.1.56. Save action
8.1.1.57. Save All action
8.1.1.58. Save Perspective As action
8.1.1.59. Search action
8.1.1.60. Select All action
8.1.1.61. Show System Menu action
8.1.1.62. Show View action
8.1.1.63. Show View Menu action
8.1.1.64. Show Whitespace Characters action
8.1.1.65. Skip All Breakpoints action
8.1.1.66. Squish Server Settings
8.1.1.67. Squish Spy Perspective action
8.1.1.68. Squish Test De­bug­ging Per­spec­tive action
8.1.1.69. Squish Test Management Perspective action
8.1.1.70. Step Into action
8.1.1.71. Step Over action
8.1.1.72. Step Return action
8.1.1.73. Suspend action
8.1.1.74. Switch to Editor action
8.1.1.75. Terminate action
8.1.1.76. Toggle Block Selection Mode action
8.1.1.77. Toggle Breakpoint action
8.1.1.78. Toggle Line Breakpoint action
8.1.1.79. Toggle Method Breakpoint action
8.1.1.80. Toggle Watchpoint action
8.1.1.81. Undo action
8.1.1.82. Use Step Filters action
8.1.1.83. Working Set action
8.1.1.84. Workspace action

The Squish IDE's Main Window provides a conventional menu bar through which all the actions and dialogs offered by the Squish IDE in the current context are accessible.

The Main Window's Menu Bar

The Main Window also provides a toolbar for instant access to a number of the Squish IDE's actions.

The Main Window's Toolbar

8.1.1.1. Add Symbolic Name action

The Add Symbolic Name action is used to add a new symbolic name to the Object Map (Section 7.11). This action can only be used when the Object Map view (Section 8.2.10) is visible. It can be invoked by clicking the Object Map view's top-most New button. The bottom-most New button can then be used to add one or more properties that Squish should use to match the new symbolic name, as discussed in the Object Map view (Section 8.2.10) section. (See also Editing an Object Map (Section 7.11.3).)

8.1.1.2. Activate Editor action

The Activate Editor action switches the focus to the last active editable view or does nothing if there isn't one. (The Squish IDE's editable views include Editor view (Section 8.2.6)s, the Object Map view (Section 8.2.10) , and the Settings view (Section 8.2.16).) The action can be invoked by clicking Window|Navigation|Activate Editor or by pressing F12.

8.1.1.3. Check Object Existence action

The Check Object Existence action marks items in the Object Map view (Section 8.2.10) as being absent () or present (). The action is only enabled if the Squish IDE is spying—for example, stopped at a breakpoint or when the AUT is running as a result of invoking the Launch AUT action (Section 8.1.1.22)—and when an item in the Object Map (Section 7.11) is selected. The action can be invoked by clicking Check Object Existence toolbar button.

8.1.1.4. Close action

The Close action closes the last active editable view or does nothing if there isn't one. (The Squish IDE's editable views include Editor view (Section 8.2.6)s, the Object Map view (Section 8.2.10), and the Settings view (Section 8.2.16).) The action can be invoked by clicking File|Close or by pressing Ctrl+W.

8.1.1.5. Close All action

The Close All action closes all the editable views or does nothing if there aren't any. (The Squish IDE's editable views include Editor view (Section 8.2.6)s, the Object Map view (Section 8.2.10), and the Settings view (Section 8.2.16).) The action can be invoked by clicking File|Close All or by pressing Shift+Ctrl+W.

8.1.1.6. Close Perspective action

The Close Perspective action closes the active perspective or does nothing if there isn't one. (The Squish IDE provides some standard perspectives; see Perspectives (Section 8.1.2).) If there is another perspective available (i.e., in the perspectives toolbar), then it will be made the active one. The Close Perspective action can be invoked by clicking Window|Close Perspective. (See also, the Close All Perspectives action (Section 8.1.1.7).)

If the standard perspectives are used this action is unlikely to be needed since the Squish IDE automatically switches between perspectives as necessary.

8.1.1.7. Close All Perspectives action

The Close All Perspectives action closes all the perspectives or does nothing if there aren't any. (The Squish IDE provides some standard perspectives; see Perspectives (Section 8.1.2).) The "Close All Perspectives" action can be invoked by clicking Window|Close All Perspectives.

If the standard perspectives are used this action is unlikely to be needed since the Squish IDE automatically switches between perspectives as necessary.

8.1.1.8. Content Assist action

The Content Assist action provides code completion and can be invoked by clicking Edit|Content Assist or by pressing Ctrl+Space. If a completion is available it is inserted; otherwise the message “No completion available” is briefly shown in the status bar. Note that completion can be attempted mid-way through typing a word or when there is no word (in which case a list of possible completion words is popped up).

8.1.1.9. Convert Line Delimiters To action

The Convert Line Delimiters To action pops up a submenu of plain text file line ending conventions. It is possible to change the line ending conventions of the active Editor view (Section 8.2.6)'s contents using this submenu. However, we do not recommend using this option. The Squish IDE is perfectly capable of detecting and handling different line ending conventions automatically, so performing manual changes should never be necessary. (And if you want to force a particular line ending convention to be used regardless of platform this can be done through the Pref­er­ences dialog (Section 8.3.17); see the General item's Workspace item's "New text file delimiter" options.)

8.1.1.10. Copy action

The Copy action () copies any selected text (e.g., in an editable view) to the clipboard. The Copy action can be invoked by clicking Edit|Copy or by pressing Ctrl+C or by invoking a context menu and clicking the Copy option for those views that have a context menu. (See also the Cut action (Section 8.1.1.12), the Paste action (Section 8.1.1.37), and the Select All action (Section 8.1.1.60).)

8.1.1.11. Customize Perspective action

The Customize Perspective action is used to pop up the Customize Perspective dialog (Section 8.3.1). This dialog is used to customize a predefined or custom perspective—for example, customizing some of the toolbars, menus, and submenus that are visible when the perspective is shown. (To change the views shown in a perspective simply close any you don't want and add new ones using the Show View action (Section 8.1.1.62).)

8.1.1.12. Cut action

The Cut action () copies any selected text (e.g., in an editable view) to the clipboard and then deletes the selected text from the view. The "Cut" action can be invoked by clicking Edit|Cut or by pressing Ctrl+X or by invoking a context menu and clicking the Cut option for those views that have a context menu with this option. (See also the Copy action (Section 8.1.1.10), the Delete action (Section 8.1.1.13), the Paste action (Section 8.1.1.37), and the Select All action (Section 8.1.1.60).)

8.1.1.13. Delete action

The Delete action () is used to delete the selected item (e.g., a test case) or the selected text (e.g., in an editable view). The Delete action can be invoked by clicking Edit|Delete or by pressing the Delete key or by invoking a context menu and clicking the Delete option for those views that have a context menu with this option. (See also the Copy action (Section 8.1.1.10) and the Cut action (Section 8.1.1.12).)

If the deletion can be undone using the Undo action (Section 8.1.1.81) the deletion is performed immediately. If the deletion is irreversible (e.g., deleting a test case) a Yes/No confirmation dialog is popped up.

Inside a Search view (Section 8.2.15) this action removes any selected matches from the view.

8.1.1.14. Delete Test Suite action

The Delete Test Suite action is used to remove a test suite from the Squish IDE's workspace—and optionally to permanently delete the entire test suite from disk. This action is invoked by clicking File|Delete Test Suite which results in a confirmation dialog being popped up. Click the No button to cancel the operation. If the Delete Test Suite on Disk checkbox is unchecked (which is the default), it is safe to click the Yes button—all that will happen is that the test suite will be removed from the workspace and any of its associated views will be closed. You can always add the test suite to the workspace afterwards by using the Open Test Suite action (Section 8.1.1.35).

If you really want to delete the entire test suite, that is both remove it from the Squish IDE's workspace and delete the test suite and all its associated test cases, test data, etc., from disk, then check the Delete Test Suite on Disk checkbox and click the Yes button. This action cannot be undone, so use with care.

8.1.1.15. File action

The Squish IDE provides two different File actions.

The first File action () invokes the Search dialog (Section 8.3.19) which is used for searching for text inside files, and forces the File Search tab to be the active tab. This action can be invoked by clicking Search|File. (See also the Search action (Section 8.1.1.59).)

The second File action performs a search in the current file for the selected text—or if no text is selected for the word containing the cursor—and presents the search results in a Search view (Section 8.2.15), showing the view if it isn't currently visible. This action can be invoked by clicking Search|Text|File. (See also the Project action (Section 8.1.1.43), the Working Set action (Section 8.1.1.83), and the Workspace action (Section 8.1.1.84).)

8.1.1.16. Find and Replace action

The Find and Replace action is used for finding and optionally replacing text in the active editable view. This action can be invoked by clicking Edit|Find and Replace or by pressing Ctrl+F and causes the Find/Replace dialog (Section 8.3.2) to pop up.

8.1.1.17. Find Next action

The Find Next action is used for finding the next occurrence of the selected text or the text that was last searched for (e.g., using the Find and Replace action (Section 8.1.1.16)). This action can be invoked by clicking Edit|Find Next or by pressing Ctrl+K.

8.1.1.18. Find Previous action

The Find Previous action is used for finding the previous occurrence of the selected text or the text that was last searched for (e.g., using the Find and Replace action (Section 8.1.1.16)). This action can be invoked by clicking Edit|Find Previous or by pressing Shift+Ctrl+K.

8.1.1.19. Import Test Resource action

The Import Test Resource action () invokes the Import Squish Resource dialog (Section 8.3.6) which is used to import scripts, test data, and verification points into a test case or a test suite. The action is invoked by clicking File|Import Test Resource. (See also the New Squish Test Data dialog (Section 8.3.11) and New Squish Test Script dialog (Section 8.3.12).)

8.1.1.20. Key Assist action

The Key Assist action pops up a window showing the Squish IDE's currently active keyboard shortcuts. This action can be invoked by clicking Help|Key Assist or by pressing Shift+Ctrl+L.

The "Key Assist" popup window

Notice that when the popup window is visible pressing Shift+Ctrl+L invokes the Pref­er­ences dialog (Section 8.3.17) at the General item's Keys item.

8.1.1.21. Last Edit Location action

The Last Edit Location action () moves the cursor to the position it had when the file being edited was last saved. This action can be invoked by clicking the Last Edit Location toolbar button or by pressing Ctrl+Q.

8.1.1.22. Launch AUT action

The Launch AUT action () runs the AUT without doing any recording, and changes the Squish IDE's perspective to the Squish Spy Perspective (Section 8.1.2.1). This means that it is possible to interact with the AUT and examine the state of its internal objects. This action can be invoked by clicking Run|Launch AUT or by pressing the Launch AUT toolbar button.

The AUT can be terminated either normally—for example, by clicking its close button—or by invoking the Quit AUT action (Section 8.1.1.46). Once the AUT has terminated, the Squish IDE returns to the Squish Test Management Perspective (Section 8.1.2.2).

8.1.1.23. Manage AUTs action

The Manage AUTs action invokes the Manage AUTs dialog (Section 8.3.8) which is used to register and unregister AUTs and AUT paths with the squishserver. This action can be invoked by clicking Edit|Server Settings|Manage AUTs.

8.1.1.24. Maximize Active View or Editor action

The Maximize Active View or Editor action is a toggle action. If the active view (e.g., an Editor view (Section 8.2.6)) is not maximized, this action maximizes the active view, i.e., makes the view occupy as much of the Squish IDE's central area as possible, and at the same time hides all the other views. If the active view is already maximized, this action reverses the effect, i.e., restores the maximized view and all the other views that were affected to their previous sizes and positions.

When a view is maximized the Squish IDE shows at least one Restore toolbar button (), plus toolbar buttons for all the other views that were visible but which have now been hidden. Clicking the Restore button has the same effect as toggling the action again. Clicking any of the toolbar buttons representing one of the views makes that view visible again, with the maximized view reducing in size to accommodate the newly visible view.

The Maximize Active View or Editor action can be toggled by clicking Window|Navigation|Maximize Active View or Editor or by pressing Ctrl+M or by clicking the view window's Maximize ()/Restore () button.

8.1.1.25. Minimize Active View or Editor action

The Minimize Active View or Editor action minimizes the view it is invoked on, i.e., it hides the view and adds a toolbar button representing the view to the Squish IDE, and also adds a Restore toolbar button () to the Squish IDE if there isn't one present already. This action can be invoked by clicking Window|Navigation|Minimize Active View or Editor or by pressing the view's Minimize button ().

This effect of this action can be reversed either by clicking the toolbar button that represents the minimized view or by clicking the Restore toolbar button ().

8.1.1.26. Move action

The Move action (invoked by clicking File|Move), is inherited from the Eclipse IDE; it is not functional in the Squish IDE.

8.1.1.27. New action

The New action provides a means of creating new test cases and test suites and of importing shared test scripts and test data. The Squish IDE provides a menu of "New" actions and a New action itself.

The New action pops up the New dialog (Section 8.3.9). This action can be invoked by clicking the New toolbar button (but not its menu indicator), or by clicking File|New...|Other..., or by pressing Ctrl+N.

The "New" actions menu can be invoked by clicking the New toolbar button's menu indicator or by clicking File|New... or by pressing Shift+Alt+N.

The "New" actions menu

If the New Test Suite menu option is invoked the New Test Suite wizard is started. This wizard is described in the tutorials. Similarly, if the Project option is invoked the New Project dialog is popped up—this has a single option “Squish Test Suite” which if chosen again leads to the New Test Suite wizard.

If the Squish Test Case option is invoked the New Squish Test Case wizard (Section 8.3.10) will pop up. Enter a test case name and click the Finish button to create a new empty test case. (The same thing can be achieved by clicking the Test Suite's view's New Test Case action, the only difference being that this way a default test name is created and is ready to be overwritten with a name of your choice.)

If the Squish Test Data File option is invoked the New Squish Test Data dialog (Section 8.3.11) is popped up. Similarly, if the Squish Script File option is invoked the New Squish Test Script dialog (Section 8.3.12) is popped up.

If the Other option is invoked, the New dialog (Section 8.3.9) is popped up, exactly the same as if the New action had been invoked directly.

8.1.1.28. New Test Case action

The New Test Case () button is used to create a new empty test case. This action can be invoked in different ways, and each way has its own slightly different behavior.

The quickest and easiest way to invoke this action is to click the Test Suites view (Section 8.2.18)'s New Test Case toolbar button. This will create a test case item in the Test Suites view (Section 8.2.18)'s Test Cases list with the name tst_case1 (or tst_case2 and so on if earlier numbered test cases already exist). The name will be selected for editing, so the test case can be immediately renamed to a name of your choice simply by typing in the new name. Once the empty test case exists it can be written either manually by typing in a script or by recording a script (which can of course be edited).

The action can also be invoked by clicking File|New Test Case or File|New|New Test Case. Both of these cause the New Squish Test Case wizard (Section 8.3.10) to pop up. Another way to pop up this wizard is to click File|New|Other (or press Ctrl+N), and then in the New dialog (Section 8.3.9) that this invokes, click the “New Test Case” item, then click the Next button.

8.1.1.29. New Test Suite action

The New Test Suite action () is used to create a new test suite. This action can be invoked in different ways, and each way has its own slightly different behavior.

The quickest and easiest way to invoke this action is to click the Test Suites view (Section 8.2.18)'s New Test Suite toolbar button. This will invoke the New Squish Test Suite wizard (Section 8.3.13). This wizard can also be invoked by clicking File|New Test Suite or File|New|New Test Suite.

Another way to pop up this wizard is to click File|New|Other (or press Ctrl+N), and then in the New dialog (Section 8.3.9) that this invokes, click the “New Test Suite” item, then click the Next button.

8.1.1.30. Next Annotation action

The Next Annotation action () moves the text cursor to the next annotation in the active Editor view (Section 8.2.6). In this context an annotation means a marker associated with a line in a test script file. For example, if a test script has a syntax error or a breakpoint the Squish IDE will mark the affected lines by putting a suitable little icon to the left of the line numbers shown in the Editor view (Section 8.2.6). This action can be invoked by clicking the Next Annotation toolbar button or by pressing Ctrl+.. If no annotation can be found the text cursor is not moved. (Note that this key combination invokes the Show Next Match action if done when a Search view (Section 8.2.15) is active.)

By default the next annotation to be moved to is an error or warning, but the kinds of annotations to move to can be selected by invoking the toobar button's menu and checking and unchecking the available annotations to suit your needs.

See also, the Prev­ious An­no­ta­tion action (Section 8.1.1.39).

8.1.1.31. Next Editor action

The Next Editor action pops up an Editor list which can be navigated by pressing Ctrl+F6 (next) and Shift+Ctrl+F6 (previous): once the Ctrl key is released the selected Editor view (Section 8.2.6) is made active.

The Next Editor action is invoked by clicking Window|Navigation|Next Editor or by pressing Ctrl+F6.

See also the Previous Editor action (Section 8.1.1.40). Note that it is almost always more convenient to use the Switch to Editor action (Section 8.1.1.74) (invoked with Shift+Ctrl+E) since that pops up a much more convenient Switch to Editor dialog (Section 8.3.22).

8.1.1.32. Next Perspective action

The Next Perspective action pops up a Perspectives list which can be navigated by pressing Ctrl+F8 (next) and Shift+Ctrl+F8 (previous): once the Ctrl key is released the selected perspective is made active.

The Next Perspective action is invoked by clicking Window|Navigation|Next Perspective or by pressing Ctrl+F8. (See also, the Previous Perspective action (Section 8.1.1.41).)

It is possible to switch directly to another perspective by clicking its toolbar button, or to choose from the available perspectives by clicking the Open Perspective toolbar button () and choosing a perspective from the list that pops up, or by clicking Window|Open Perspective and choosing a perspective from those listed in the submenu.

In practice it is rarely necessary to manually change between the standard Squish perspectives since the Squish IDE switches between them automatically depending on context.

8.1.1.33. Next View action

The Next View action pops up a Views list which can be navigated by pressing Ctrl+F7 (next) and Shift+Ctrl+F7 (previous): once the Ctrl key is released the selected view is made active.

The Next View action is invoked by clicking Window|Navigation|Next View or by pressing Ctrl+F7. (See also, the Previous View action (Section 8.1.1.42).)

It is possible to switch directly to another (visible) view simply by clicking it, or to choose from the available views by clicking Window|Show View and choosing a view from those listed in the submenu, or by clicking the Other submenu item and choosing a view from the Show View dialog (Section 8.3.20).

8.1.1.34. Open File action

The Open File action pops up an Open File dialog from which a file can be chosen. If the file is of a type recognized by Squish it is opened inside the Squish IDE; otherwise the Squish IDE tries to open the file via the operating system—for example, using the file association on Windows and macOS to invoke an appropriate application to open the file. This action is invoked by clicking File|Open File.

8.1.1.35. Open Test Suite action

The Open Test Suite action () pops up the Open Test Suite dialog. This dialog presents a directory tree view—navigate to the test suite you want to open and once it is selected click the OK button to open it. This action is invoked by clicking File|Open Test Suite.

The Squish IDE can hold any number of test suites. The current one is shown in the Test Suites view (Section 8.2.18)'s combobox (which can also be used to change the current test suite.) To remove a test suite from the Squish IDE's workspace use the Delete Test Suite action (Section 8.1.1.14).

8.1.1.36. Open Perspective action

The Open Perspective action () is used to open (i.e., change to) a perspective. The action is invoked by clicking Window|Open Perspective and choosing a perspective from the submenu, or by clicking the Other submenu item and choosing a perspective from the Open Perspective dialog (Section 8.3.16).

It is possible to switch directly to another perspective by clicking its toolbar button, or to choose from the available perspectives by clicking the Open Perspective toolbar button () and choosing a perspective from the list that pops up.

In practice it is rarely necessary to manually change between the standard Squish perspectives since the Squish IDE switches between them automatically depending on context.

8.1.1.37. Paste action

The Paste action () inserts any text that is in the clipboard into the active Editor view (Section 8.2.6) at the current cursor position. The Paste action can be invoked by clicking Edit|Paste or by pressing Ctrl+V or by invoking a context menu and clicking the Paste option for those views that have a context menu. (See also the Copy action (Section 8.1.1.10) and the Cut action (Section 8.1.1.12).)

8.1.1.38. Preferences action

The Preferences action invokes the Pref­er­ences dialog (Section 8.3.17) through which much of the Squish IDE's behavior can be customized. This action can be invoked by clicking Preferences.

8.1.1.39. Prev­ious An­no­ta­tion action

The Previous Annotation action () moves the text cursor to the previous annotation in the active Editor view (Section 8.2.6). In this context an annotation means a marker associated with a line in a test script file. For example, if a test script has a syntax error or a breakpoint the Squish IDE will mark the affected lines by putting a suitable little icon to the left of the line numbers shown in the Editor view (Section 8.2.6). This action can be invoked by clicking the Previous Annotation toolbar button or by pressing Ctrl+,. If no annotation can be found the text cursor is not moved. (Note that this key combination invokes the Show Previous Match action if done when a Search view (Section 8.2.15) is active.)

By default the next annotation to be moved to is an error or warning, but the kinds of annotations to move to can be selected by invoking the toobar button's menu and checking and unchecking the available annotations to suit your needs.

See also, the Next Annotation action (Section 8.1.1.30).

8.1.1.40. Previous Editor action

The Previous Editor action pops up an Editor list which can be navigated by pressing Ctrl+F6 (next) and Shift+Ctrl+F6 (previous): once the Ctrl key is released the selected editor view is made active.

The Previous Editor action is invoked by clicking Window|Navigation|Previous Editor or by pressing Shift+Ctrl+F6.

See also the Next Editor action (Section 8.1.1.31). Note that it is almost always more convenient to use the Switch to Editor action (Section 8.1.1.74) (invoked with Shift+Ctrl+E) since that pops up a much more convenient Switch to Editor dialog (Section 8.3.22).

8.1.1.41. Previous Perspective action

The Previous Perspective action pops up a Perspectives list which can be navigated by pressing Ctrl+F8 (next) and Shift+Ctrl+F8 (previous): once the Ctrl key is released the selected perspective is made active.

The Previous Perspective action is invoked by clicking Window|Navigation|Previous Perspective or by pressing Shift+Ctrl+F8. (See also, the Next Perspective action (Section 8.1.1.32).)

It is possible to switch directly to another perspective by clicking its toolbar button, or to choose from the available perspectives by clicking the Open Perspective toolbar button () and choosing a perspective from the list that pops up, or by clicking Window|Open Perspective and choosing a perspective from those listed in the submenu.

In practice it is rarely necessary to manually change between the standard Squish perspectives since the Squish IDE switches between them automatically depending on context.

8.1.1.42. Previous View action

The Previous View action pops up a Views list which can be navigated by pressing Ctrl+F7 (next) and Shift+Ctrl+F7 (previous): once the Ctrl key is released the selected view is made active.

The Previous View action is invoked by clicking Window|Navigation|Previous View or by pressing Shift+Ctrl+F7. (See also, the Next View action (Section 8.1.1.33).)

It is possible to switch directly to another (visible) view simply by clicking it, or to choose from the available views by clicking Window|Show View and choosing a view from those listed in the submenu, or by clicking the Other submenu item and choosing a view from the Show View dialog (Section 8.3.20).

8.1.1.43. Project action

The Project action performs a search in the current project's files for the selected text—or if no text is selected for the word containing the cursor—and presents the search results in a Search view (Section 8.2.15), showing the view if it isn't currently visible. This action can be invoked by clicking Search|Text|Project. (See also the File action (Section 8.1.1.15), the Working Set action (Section 8.1.1.83), and the Workspace action (Section 8.1.1.84).)

8.1.1.44. Properties action

The Properties action invokes a Properties dialog which shows the file properties—including the path, size, and permissions—of the file shown in the active editor. This action is invoked by clicking File|Properties or by pressing Alt+Enter.

8.1.1.45. Quick Access action

The Quick Access action pops up a search dialog for finding actions, perspectives, and views in the Squish IDE. Once the dialog is visible simply start typing the name of the action, perspective, or view you want and a list of matches (if any) will be shown. You can then use the up and down arrow keys to select a choice and press Enter to choose it—or press Esc to cancel. This action is invoked by clicking Window|Navigation|Quick Access or by pressing Ctrl+3.

8.1.1.46. Quit AUT action

The Quit AUT action () is used to terminate an AUT that has been launched using the Launch AUT action (Section 8.1.1.22). This action can be invoked by clicking Run|Quit AUT or by pressing the Quit AUT toolbar button. Once the AUT has terminated, the Squish IDE returns to the Squish Test Management Perspective (Section 8.1.2.2).

8.1.1.47. Re­cord Snip­pet action

The Record Snippet action () causes Squish to launch the AUT and begin recording a snippet into the active test case. To finish recording press the Control Bar Window (Section 8.1.3)'s Stop Recording button. Once the recording is stopped the recorded script is inserted into the active editor's text at the current cursor position. Note that the recording will begin with a call to the startApplication function; it is best to delete this line if the script already contains this call earlier on. (To cancel recording press the Control Bar Window (Section 8.1.3)'s Cancel button—in this case the test case is left unchanged.)

The Record Snippet action can be invoked by clicking Run|Record Snippet. Do not click the Record Test Case button () in the Test Suites view (Section 8.2.18)'s Test Cases list to insert a snippet since this will replace the entire test case's script with the recorded snippet. (If you do this by mistake, immediately invoke the Undo action (Section 8.1.1.81) to restore the original test case's script.)

See also, How to Edit and Debug Test Scripts (Section 5.21).

8.1.1.48. Record Test Case action

The Record Test Case action () causes Squish to launch the AUT and begin recording a new test script in the active test case. If the test case already has a test script the newly recorded script will completely replace the original, so it is normal to only use this action when you have created a new empty test case. (If you start recording a new test script on a non-empty test case by mistake click the Control Bar Window (Section 8.1.3)'s Cancel button to stop the recording—in this case the test case is left unchanged. If you completed the recording and overwrote a non-empty test case by mistake, immediately invoke the Undo action (Section 8.1.1.81) to restore the original test case's script.)

The Record Test Case action can be invoked by clicking the Record Test Case button () that's to the right of the test case listed in the Test Suites view (Section 8.2.18)'s Test Cases list, or by clicking Run|Record Test Case.

8.1.1.49. Redo action

The Redo action () redoes the action that was previously undone with the Undo action (Section 8.1.1.81) if there was one. This action can be invoked repeatedly to redo each action that was undone, one at a time. This action can be invoked by clicking Edit|Redo or by pressing Ctrl+Y.

8.1.1.50. Refresh action

The Refresh action () reloads a file (e.g., in an editor view) that has been changed outside the Squish IDE—or does nothing if no external changes have been made. This action can be invoked by clicking File|Refresh or by pressing F5. (Externally editing files that are shown in the Squish IDE is not recommended. It is best to at least close the relevant editor view before doing an external edit.)

8.1.1.51. Remove All Breakpoints action

The Remove All Breakpoints action () removes all the breakpoints. This means that if the test is resumed (using the Resume action (Section 8.1.1.54)) it will run to completion (or to an error if there is one); and will do so in future unless one or more new breakpoints are added. This action can be invoked by clicking Run|Remove All Breakpoints. (See also, the Toggle Breakpoint action (Section 8.1.1.77) which is used to add breakpoints.)

8.1.1.52. Rename action

The Rename action (invoked by clicking File|Rename), is inherited from the Eclipse IDE; it is not functional in the Squish IDE.

8.1.1.53. Reset Perspective action

The Reset Perspective action pops up a Reset Perspective OK/Cancel dialog. If you click the OK button the current perspective will be reset to its default settings. This action can be in voked by clicking Window|Reset Perspective.

8.1.1.54. Resume action

The Resume action () resumes the execution of a test case that has stopped at a breakpoint. This action can be invoked by clicking Run|Resume, or by pressing F8, or by clicking the Debug view (Section 8.2.5)'s Resume toolbar button (). (See also, the Terminate action (Section 8.1.1.75), the Step Over action (Section 8.1.1.71), the Squish Test Debugging Perspective (Section 8.1.2.3), and How to Edit and Debug Test Scripts (Section 5.21).)

8.1.1.55. Run Test Case action

The Run Test Case action () runs (replays) the selected test case. This action can be invoked by clicking the Run Test Case button that's to the right of the test case listed in the Test Suites view (Section 8.2.18)'s Test Cases list, or by clicking Run|Run Test Case.

It is also possible to run all of a test suite's test cases by clicking the Run Test Suite toolbar button ().

8.1.1.56. Save action

The Save action () saves any unsaved changes in the active editable view. (The Squish IDE's editable views include editor views, the Object Map view (Section 8.2.10), and Settings view (Section 8.2.16).) The Save action can be invoked by clicking the Save toolbar button or by clicking File|Save or by pressing Ctrl+S. (See also Save All action (Section 8.1.1.57).)

8.1.1.57. Save All action

The Save All action () saves any unsaved changes in all the editable views. (The Squish IDE's editable views include editor views, the Object Map view (Section 8.2.10), and Settings view (Section 8.2.16).) The Save All action can be invoked by clicking File|Save All or by pressing Shift+Ctrl+S.

By default the Squish IDE will always prompt to save unsaved changes when terminated. Also the Squish IDE is normally set to automatically save unsaved changes every five minutes. (These settings can be changed using the Pref­er­ences dialog (Section 8.3.17); see the General item's Workspace item's "Workspace save interval" option.)

8.1.1.58. Save Perspective As action

The Save Perspective As action pops up a Save Perspective As dialog. You can enter a perspective name of your choice and if you then click the OK button, a new perspective will be saved under the name you specified and with all the current perspective's views and their positions and sizes.

If you want to delete a perspective you no longer need, use the Preferences action (Section 8.1.1.38) to open the Pref­er­ences dialog (Section 8.3.17), and navigate to the General item's Perspectives item. Then click the perspective you want to delete and click the Delete button. The Squish IDE depends on the availability of the Squish Test Management Perspective (Section 8.1.2.2), the Squish Test Debugging Perspective (Section 8.1.2.3), and the Squish Spy Perspective (Section 8.1.2.1), so please don't delete any of these.

8.1.1.59. Search action

The Search action () invokes the Search dialog (Section 8.3.19) which is used for searching for text inside files. The action can be invoked by clicking Search|Search or by pressing Ctrl+H. (See also the File action (Section 8.1.1.15).)

8.1.1.60. Select All action

The Select All action selects all the text in the active view for those views that support the operation (e.g., editor views, the Test Results view (Section 8.2.17), the Test Summary view (Section 8.2.19), and the Runner/Server Log view (Section 8.2.13). Once selected the text can be copied to the clipboard using the Copy action (Section 8.1.1.10). (Note that when performing this action in the Test Results view (Section 8.2.17) only the visible text is copied—so make sure you expand any results for which you want to copy the details before selecting.)

The Select All action can be invoked by clicking Edit|Select All or by pressing Ctrl+A or by invoking a context menu and clicking the Select All option for those views that have a context menu.

8.1.1.61. Show System Menu action

The Show System Menu action pops up the active view's system menu. This menu normally offers options to close, minimize (iconize), and maximize the view, and in some cases, view-type-specific options. This action is invoked by clicking Window|Navigation|Show System Menu or by pressing Alt+-.

8.1.1.62. Show View action

The Show View action is used to open a view that isn't already open. The action can be invoked in different ways, and each way has its own slightly different behavior.

One way to open a view is by clicking Window|Show View and choosing a view from those listed in the submenu. If the desired view is not listed click the Other option to pop up the Show View dialog (Section 8.3.20).

Another way to open a view is by pressing Shift+Alt+Q, Q—this will pop up the Show View dialog (Section 8.3.20).

The last way to open a view is by pressing Shift+Alt+Q and waiting a moment. A list of Show View commands will pop up; choose the first one (Show View) to pop up the Show View dialog (Section 8.3.20); or choose any of the others to open the specified view. All of the views listed can also be opened directly by using the keyboard shortcut shown besides their names in the pop up list (and listed in the Keyboard Shortcuts (Section 8.4) section)—they all have the form Shift+Alt+Q, letter.

8.1.1.63. Show View Menu action

The Show View Menu action pops up the current view's view menu (if it has one). This action can be invoked by clicking Window|Navigation|Show View Menu or by pressing Ctrl+F10.

8.1.1.64. Show Whitespace Characters action

The Show Whitespace Characters action () toggles the display of whitespace characters in editor views. When active, spaces ares shown as cdots (vertically centered periods), tabs are shown as right-pointing chevrons, and newlines are shown as paragraph marks. This action can be toggled on or off by clicking the Show Whitespace Characters toolbar button ().

8.1.1.65. Skip All Breakpoints action

The Skip All Breakpoints action marks all the breakpoints so that they will be skipped if the test is resumed (using the Resume action (Section 8.1.1.54)). This means that the test will run to completion (or to an error if there is one). This action can be invoked by clicking Run|Skip All Breakpoints. (Note that this action is not functional in the Squish IDE versions 4.0.0 and 4.0.1.)

8.1.1.66. Squish Server Settings

The Squish Server Settings action invokes the Squish Server Settings dialog (Section 8.3.21). This dialog can be used to control various aspects of the squishserver that the Squish IDE uses when recording and playing back tests.

(Added with Squish 4.2.)

8.1.1.67. Squish Spy Perspective action

The Squish Spy Perspective action () changes the current perspective to the Squish Spy Perspective (Section 8.1.2.1). In practice this is rarely ever necessary since the Squish IDE automatically switches to the appropriate perspective depending on the context. This action can be invoked by clicking Window|Open Perspective|Squish Spy or by pressing the Squish Spy perspective toolbar button. (A more long-winded way of changing to this perspective is to click Window|Open Perspective|Other, to pop up the Open Perspective dialog, then click the perspective you want then click the OK button.)

(See also, How to Use the Spy (Section 5.21.3).)

8.1.1.68. Squish Test De­bug­ging Per­spec­tive action

The Squish Test Debugging Perspective action () changes the current perspective to the Squish Test Debugging Perspective (Section 8.1.2.3). In practice this is rarely ever necessary since the Squish IDE automatically switches to the appropriate perspective depending on the context. This action can be invoked by clicking Window|Open Perspective|Squish Test Debugging or by pressing the Squish Test Debugging perspective toolbar button. (A more long-winded way of changing to this perspective is to click Window|Open Perspective|Other, to pop up the Open Perspective dialog, then click the perspective you want then click the OK button.)

8.1.1.69. Squish Test Management Perspective action

The Squish Test Management Perspective action () changes the current perspective to the Squish Test Management Perspective (Section 8.1.2.2). (This is the default perspective, although the default can be changed by going to the Pref­er­ences dialog (Section 8.3.17), then navigating to the Perpectives item and setting a different default.) In practice this is rarely ever necessary since the Squish IDE automatically switches to the appropriate perspective depending on the context. This action can be invoked by clicking Window|Open Perspective|Squish Test Management or by pressing the Squish Test Management perspective toolbar button. (A more long-winded way of changing to this perspective is to click Window|Open Perspective|Other, to pop up the Open Perspective dialog, then click the perspective you want then click the OK button.)

8.1.1.70. Step Into action

The Step Into action () continues the execution of a test case that has been stopped—for example, at a breakpoint. If the statement to execute is a function call, this action steps into the function and execute's the function's first statement. This action can be invoked by clicking Run|Step Into, or by pressing F5, or by clicking the Debug view (Section 8.2.5)'s Step Into toolbar button (). (See also, the Step Over action (Section 8.1.1.71), the Step Return action (Section 8.1.1.72), the Resume action (Section 8.1.1.54), the Squish Test Debugging Perspective (Section 8.1.2.3), and How to Edit and Debug Test Scripts (Section 5.21).)

8.1.1.71. Step Over action

The Step Over action () continues the execution of a test case that has been stopped—for example, at a breakpoint. If the statement to execute is a function call, this action executes the call (without stepping into the called function) ready to continue from the statement that follows the call. This action can be invoked by clicking Run|Step Over, or by pressing F6, or by clicking the Debug view (Section 8.2.5)'s Step Over toolbar button (). (See also, the Step Into action (Section 8.1.1.70), the Step Return action (Section 8.1.1.72), the Resume action (Section 8.1.1.54), the Squish Test Debugging Perspective (Section 8.1.2.3), and How to Edit and Debug Test Scripts (Section 5.21).)

8.1.1.72. Step Return action

The Step Return action () continues the execution of a test case that has been stopped—for example, at a breakpoint. If the statement to execute is inside a function call (e.g., as the result of invoking the Step Over action (Section 8.1.1.71) earlier), this action immediately completes the execution of the function, ready to continue from the statement that follows the call to the function that has just been finished. This action can be invoked by clicking Run|Step Return, or by pressing F7, or by clicking the Debug view (Section 8.2.5)'s Step Return toolbar button (). (See also, the Step Into action (Section 8.1.1.70), the Step Over action (Section 8.1.1.71), the Resume action (Section 8.1.1.54), and the Squish Test Debugging Perspective (Section 8.1.2.3).)

8.1.1.73. Suspend action

The Suspend action (invoked by clicking Run|Suspend), is inherited from the Eclipse IDE; it is not needed or functional in the Squish IDE.

8.1.1.74. Switch to Editor action

The Switch to Editor action pops up the Switch to Editor dialog (Section 8.3.22) through which it is possible to choose an editor to make active from those that are currently open. This action can be invoked by clicking Window|Navigation|Switch to Editor or by pressing Shift+Ctrl+E. If you don't have many Editor view (Section 8.2.6)s open it is usually quicker and easier to simply click the relevant tab.

8.1.1.75. Terminate action

The Terminate action () terminates the execution of a test case that has stopped at a breakpoint. This action can be invoked by clicking Run|Terminate, or by pressing Ctrl+F2, or by clicking the Debug view (Section 8.2.5)'s Terminate toolbar button (). (See also, the Resume action (Section 8.1.1.54) the Squish Test Debugging Perspective (Section 8.1.2.3), and How to Edit and Debug Test Scripts (Section 5.21).)

8.1.1.76. Toggle Block Selection Mode action

The Toggle Block Selection Mode action () toggles between the standard and block selection modes. In standard mode text is selected linearly (i.e., as if the entire file was a single very long string of text) from the cursor position to the position dragged to by the mouse or selected to by keyboard navigation (with the Shift key held down). In block mode text is selected as a rectangle with the cursor position marking one corner and the position dragged to by the mouse or selected to by keyboard navigation (with the Shift key held down) marking the diagonally opposite corner. The selection mode defaults to standard mode and can be toggled between standard and block mode by pressing the Toggle Block Selection Mode toolbar button () or by pressing Shift+Alt+A.

8.1.1.77. Toggle Breakpoint action

The Toggle Breakpoint action () toggles between a breakpoint being present or absent in the line containing the cursor. Breakpoints can be added or removed using this action when editing a test script or when a test run has been stopped (i.e., at a breakpoint). This action can be invoked by clicking Run|Toggle Breakpoint or by pressing Shift+Ctrl+B.

8.1.1.78. Toggle Line Breakpoint action

The Toggle Line Breakpoint action () toggles between a breakpoint being present or absent in the line containing the cursor. This action can be invoked by clicking Run|Toggle Line Breakpoint. It is almost always more convenient to use the Toggle Breakpoint action (Section 8.1.1.77) instead.

8.1.1.79. Toggle Method Breakpoint action

The Toggle Method Breakpoint action (; invoked by clicking Run|Toggle Method Breakpoint) is inherited from the Eclipse IDE; it is not functional in the Squish IDE.

8.1.1.80. Toggle Watchpoint action

The Toggle Watchpoint action (; invoked by clicking Run|Toggle Watchpoint) is inherited from the Eclipse IDE; it is not functional in the Squish IDE.

8.1.1.81. Undo action

The Undo action () undoes the action that was just done (or redone with the Redo action (Section 8.1.1.49)) if there was one. This action can be invoked repeatedly to undo each action that was done, one at a time. This action can be invoked by clicking Edit|Undo or by pressing Ctrl+Z.

8.1.1.82. Use Step Filters action

The "Use Step Filters" toggle action (; invoked by clicking Run|Use Step Filters, or by pressing Shift+F5), is inherited from the Eclipse IDE; it is not functional in the Squish IDE.

8.1.1.83. Working Set action

The Working Set action pops up the Select Working Sets dialog. Once a working set is chosen or created, if you then click the OK button, the action then goes on to perform a search in the working set's files. The search is for the selected text—or if no text is selected for the word containing the cursor—and the search results are presented in a Search view (Section 8.2.15), showing the view if it isn't currently visible. This action can be invoked by clicking Search|Text|Working Set. (See also the File action (Section 8.1.1.15), the Project action (Section 8.1.1.43), and the Workspace action (Section 8.1.1.84).)

8.1.1.84. Workspace action

The Workspace action performs a search in the current workspace's files for the selected text—or if no text is selected for the word containing the cursor—and presents the search results in a Search view (Section 8.2.15), showing the view if it isn't currently visible. This action can be invoked by clicking Search|Text|Workspace or by pressing Ctrl+Alt+G. (See also the File action (Section 8.1.1.15), the Project action (Section 8.1.1.43), and the Working Set action (Section 8.1.1.83).)

8.1.2. Perspectives

The Squish IDE provides three default perspectives which provide all the necessary functionality. It is also possible to create custom perspectives—either from scratch or based on any of the Squish perspectives—but this isn't often needed since the Squish IDE remembers any changes made to the default perspectives and applies them whenever one of the perspectives is opened.

8.1.2.1. Squish Spy Perspective

The Squish Spy Perspective is automatically switched to by the Squish IDE when the Launch AUT action (Section 8.1.1.22) is invoked. This perspective shows the Application Objects view (Section 8.2.1), the Properties view (Section 8.2.12), and the Methods view (Section 8.2.9), in addition to views already present such as the Test Suites view (Section 8.2.18) and any open Editor view (Section 8.2.6)s. (This perspective can also be switched to using by clicking the Squish Spy Perspective toolbar button, but this is rarely useful.)

The Squish Spy Perspective

To return to the default perspective (normally the Squish Test Management Perspective (Section 8.1.2.2)), invoke the Quit AUT action (Section 8.1.1.46).

See the documentation for the individual views for further details, and also How to Use the Spy (Section 5.21.3).

8.1.2.2. Squish Test Management Perspective

The Squish Test Management Perspective is the default perspective—the Squish IDE starts with this perspective and this perspective is automatically switched to by the Squish IDE when one of the other perspectives is closed. This perspective shows the Test Suites view (Section 8.2.18), the Test Results view (Section 8.2.17), and the Test Summary view (Section 8.2.19), in addition to any open Editor view (Section 8.2.6)s. (This perspective can also be switched to using by clicking the Squish Test Management Perspective toolbar button.)

The Squish Test Management Perspective

If the Runner/Server Log view (Section 8.2.13) is opened—see the Show View action (Section 8.1.1.62)—it is shown in this perspective.

See the documentation for the individual views for further details.

8.1.2.3. Squish Test Debugging Perspective

The Squish Test Debugging Perspective is automatically switched to by the Squish IDE when a breakpoint is reached. This perspective shows the Application Objects view (Section 8.2.1), the Properties view (Section 8.2.12), the Methods view (Section 8.2.9), the Debug view (Section 8.2.5), the Console view (Section 8.2.3), and the Variables view (Section 8.2.20), in addition to any open Editor view (Section 8.2.6)s. (This perspective can also be switched to using by clicking the Squish Test Debugging Perspective toolbar button, but this is rarely useful.)

The Squish Test Debugging Perspective

To return to the default perspective (normally the Squish Test Management Perspective (Section 8.1.2.2)), either complete the test run by invoking the Resume action (Section 8.1.1.54), or cancel the test run by invoking the Terminate action (Section 8.1.1.75).

See the documentation for the individual views for further details.

8.1.3. Control Bar Window

When a test or test snippet is recorded, or when a test is run, the Control Bar Window is made visible and the Squish IDE's main window is hidden. Once the test run or recording is completed (or canceled), the Control Bar Window is hidden and the Squish IDE's main window is made visible.

The Control Bar Window

The Control Bar Window has some toolbar buttons and a line of status text. Each toolbar's action is described below.

8.1.3.1. Stop Recording action

The Stop Recording action () is only enabled during recording. Its main purpose is to finish the recording of a snippet into an existing test. But it can also be used if you want to finish recording a test but want to leave Squish to actually close the AUT. And it can also be used if a mistake is made and you would rather abandon and start again. (See also, How to Edit and Debug Test Scripts (Section 5.21).)

8.1.3.2. Verify > Properties action

The Verify > Properties action () is only enabled during recording. If clicked the Control Bar Window is hidden and the Squish IDE's main window is made visible (possibly obscuring the AUT). The Squish IDE will automatically be switched to the Squish Spy Perspective (Section 8.1.2.1) with the Verification Point Creator view (Section 8.2.21) visible, ready for verifications to be inserted. After inserting one or more verification points the Squish IDE's main window will again be hidden and the Control Bar Window made visible so that recording can continue. (You can also resume recording without inserting any verifications by closing the Verification Point Creator view (Section 8.2.21).)

8.1.3.3. Verify > Screenshot action

The Verify > Screenshot action () is only enabled during recording. If clicked the Control Bar Window is hidden and the Squish IDE's main window is made visible (possibly obscuring the AUT). The Squish IDE will automatically be switched to the Squish Spy Perspective (Section 8.1.2.1) with the Verification Point Creator view (Section 8.2.21) visible, ready for verifications to be inserted. After inserting one or more verification points the Squish IDE's main window will again be hidden and the Control Bar Window made visible so that recording can continue. (You can also resume recording without inserting any verifications by closing the Verification Point Creator view (Section 8.2.21).)

8.1.3.4. Verify > Table action

The Verify > Table action () is only enabled during recording. If clicked the Control Bar Window is hidden and the Squish IDE's main window is made visible (possibly obscuring the AUT). The Squish IDE will automatically be switched to the Squish Spy Perspective (Section 8.1.2.1) with the Verification Point Creator view (Section 8.2.21) visible, ready for verifications to be inserted. After inserting one or more verification points the Squish IDE's main window will again be hidden and the Control Bar Window made visible so that recording can continue. (You can also resume recording without inserting any verifications by closing the Verification Point Creator view (Section 8.2.21).)

8.1.3.5. Verify > Visual action

The Verify > Visual action () is only enabled during recording. If clicked the Control Bar Window is hidden and the Squish IDE's main window is made visible (possibly obscuring the AUT). The Squish IDE will automatically be switched to the Squish Spy Perspective (Section 8.1.2.1) with the Verification Point Creator view (Section 8.2.21) visible, ready for verifications to be inserted. After inserting one or more verification points the Squish IDE's main window will again be hidden and the Control Bar Window made visible so that recording can continue. (You can also resume recording without inserting any verifications by closing the Verification Point Creator view (Section 8.2.21).)

8.1.3.6. Verify > Search Image action

The Verify > Search Image action () is only enabled during recording. If clicked the Squish IDE will switch into a mode featuring the insertion of a test.imagePresent function call into the test script.

8.1.3.7. Verify > OCR Text action

The Verify > OCR Text action () is only enabled during recording. If clicked the Squish IDE will switch into a mode featuring the insertion of a test.ocrTextPresent function call into the test script.

8.1.3.8. Insert > mouseClick(<Image>) action

The Insert > mouseClick(<Image>) action () is only enabled during recording. If clicked the Squish IDE will switch into a mode featuring the insertion of a mouseClick function operating based on the location of an image on the screen.

8.1.3.9. Insert > doubleClick(<Image>) action

The Insert > doubleClick(<Image>) action () is only enabled during recording. If clicked the Squish IDE will switch into a mode featuring the insertion of a doubleClick function operating based on the location of an image on the screen.

8.1.3.10. Insert > tapObject(<Image>) action

The Insert > tapObject(<Image>) action () is only enabled during recording. If clicked the Squish IDE will switch into a mode featuring the insertion of a tapObject touch function operating based on the location of an image on the screen.

8.1.3.11. Insert > mouseClick(<OCR>) action

The Insert > mouseClick(<OCR>) action () is only enabled during recording. If clicked the Squish IDE will switch into a mode featuring the insertion of a mouseClick function operating based on the location of a specified text.

8.1.3.12. Insert > doubleClick(<OCR>) action

The Insert > doubleClick(<OCR>) action () is only enabled during recording. If clicked the Squish IDE will switch into a mode featuring the insertion of a doubleClick function operating based on the location of a specified text.

8.1.3.13. Insert > tapObject(<OCR>) action

The Insert > tapObject(<OCR>) action () is only enabled during recording. If clicked the Squish IDE will switch into a mode featuring the insertion of a tapObject touch function operating based on the location of a specified text.

8.1.3.14. Insert > Comment action

The Insert > Comment action () is only enabled during recording. If clicked an Insert Comment dialog will open and offer the insertion of a free-form comment into the test script. After the insertion the recording can continue.

8.1.3.15. Cancel action

The Cancel action () is always enabled. If clicked, the test or snippet being recorded or the test replay will be cancelled. In the case of recording, no recorded test script lines will be inserted into the test case. In the case of a test replay, any test results that have been logged so far are retained, but the replay is canceled, so no more test results are logged.